Weird noise from right front hub

Angle mods and engine builds. Even how to drift or build a boat. Post it here.
Post Reply
User avatar
Gandhi
Posts: 140
Joined: Wed Jun 27, 2012 6:17 pm
Location: Northern VA

Weird noise from right front hub

Post by Gandhi » Wed Apr 24, 2013 12:21 am

So I replaced my tension rods, control arms, tie rods, and 3 lug studs the other day and had my whole hub apart. I took the caliper apart at one point too. I put it all back together and had no problems for a couple of days. I was on a pizza run and took a turn pretty fast and shortly afterward I noticed a rubbing sound. The longer I drove the louder it got and it started sounding like metal on metal after about a mile. I got it home and took it apart again and I couldn't see anything wrong with it. I took the caliper off and made sure that the pads were seated and they're fine, but when I put the caliper back on it wants to grip the rotor a tiny bit. I can still spin the rotor by hand pretty easily but I think it's rubbing the pads the tiniest little bit. Do I have a stuck piston or is a tiny bit of grip normal? If that's normal what else could be causing this noise? I'm guessing it has something to do with one of the things that I dicked with.
Last edited by Gandhi on Wed Apr 24, 2013 1:10 am, edited 1 time in total.
User avatar
Yoshi
Site Admin
Posts: 6610
Joined: Thu May 13, 2010 1:25 pm

Re: Weird noise from right front hub

Post by Yoshi » Wed Apr 24, 2013 1:05 am

backing plate aka brake dust shield maybe almost contacting rotor and on turning contacting rotor?
Image
Status: HG repair. 488wtq though!
User avatar
Gandhi
Posts: 140
Joined: Wed Jun 27, 2012 6:17 pm
Location: Northern VA

Re: Weird noise from right front hub

Post by Gandhi » Wed Apr 24, 2013 1:31 am

Also when I was bleeding the brakes it was like Kill Bill. Bad brake hose?
Last edited by Gandhi on Wed Apr 24, 2013 1:43 am, edited 1 time in total.
User avatar
Yoshi
Site Admin
Posts: 6610
Joined: Thu May 13, 2010 1:25 pm

Re: Weird noise from right front hub

Post by Yoshi » Wed Apr 24, 2013 1:36 am

well does the sound go away when you press the brakes? What are the exact circumstances it makes the sound? The more explicit you are, the better.
Image
Status: HG repair. 488wtq though!
User avatar
Gandhi
Posts: 140
Joined: Wed Jun 27, 2012 6:17 pm
Location: Northern VA

Re: Weird noise from right front hub

Post by Gandhi » Thu Apr 25, 2013 4:59 pm

It wound up that the inside of my brake line was collapsing causing my calipers to stick shut a little bit instead of fully retracting when I lifted my foot off of the brake. There was a point when I took off the hub that I put a ton of weight on that line accidentally. It's all better now though
User avatar
Yoshi
Site Admin
Posts: 6610
Joined: Thu May 13, 2010 1:25 pm

Re: Weird noise from right front hub

Post by Yoshi » Thu Apr 25, 2013 5:08 pm

Makes sense. live and learn I guess.
Image
Status: HG repair. 488wtq though!
Post Reply